Thursday, September 20, 2007

Quake for S60 3rd edition FP1

Quake for S60 3rd edition FP1 This is a port of the infamous first person shooter for the S60 3rd Edition FP1 based phones. The only thing that is not working is network play.
This port requires an S60 3rd Edition Feature Pack 1 phone (e.g. N95 or E90) and ARMv6 processor. It will not work on older S60 3rd Edition (non-FP1) phones. You need to install PIPS C Runtime libraries for this software to work.
1. Find a suitable datafile (either shareware, or the full version form original PC version)
2. Create "quake1" folder to the root of your memorycard
3a. If you have the full version, just copy the "ID1" directory to "quake1" directory.
3b. If you have only a shareware .pak file, create "ID1" folder to "quake1" directory and the copy the shareware pak-file there
4. If you want to have cdaudio aswell, create "cdaudio" folder to the "quake1" folder. Then put the audio files as .mp3 to the "cdaudio" folder, remember to rename the files from 1.mp3 throught 10.mp3. I don't know what bitrate is the best, but I have used 256kbps and it has impact of 0.1 fps to the performance. If you do not have the required audio files, the background music is just not played.
5. install the Symbian P.I.P.S. c-runtime library, and the install the suitable version of quake.

quake_v101_armv6_fpu.sisx - this version is for phones which have a floating point unit (ie. N95)
quake_v101_armv6_nofpu.sisx - a non fpu build for phone without fpu (ie. 6290)
pips_s60_wp.sis - Symbian P.I.P.S. C-Runtime library. Required by both of the game versions
Author homepage
List of S60 3rd edition FP1
Video form youtube

via: ,

No comments: